Chipper Board

Prototype and Program ATtiny Chips

Kickstarter Campaign – Buy Now

Assembled Chipper

Created to make ATtiny chips easier to work with the Chipper Shield – a custom PCB – is on its 3rd generation and encompasses all of the core components to get your next project up and running.

Purchase A ChipperChipper Circuit Board Files – Sponsors

  • 100% Arduino compatible
  • Program ATtiny 85/45/25/15/13 84/44/24 2313/4313 chips.
  • Debug your program through 2 LEDs and broken out sensor port.
  • Compatible with either an Arduino board or AVR programmer
  • House sensors on the proto area of the board with access to broken out power and ground.
  • Reset a chip mid-program through the reset button.

Chipper Board Companion Guides:

Datasheets:

Photos:

This slideshow requires JavaScript.

49 thoughts on “Chipper Board

  1. Pingback: Chipper Board – Live Kickstarter | Built By Ben

  2. Pingback: Chipper – ATtiny Programming and Prototyping Shield - Hacked Gadgets – DIY Tech Blog

  3. Pingback: Chipper – ATtiny Programming and Prototyping Shield | Buying

  4. Pingback: Chipper – ATtiny Programming and Prototyping Shield | DIY Clipping

  5. Is that a tiny breadboarding area in the left top corner of the board or those holes are connected to something? BTW, the “perpendicular shield” concept is pretty cool! I always end up with more board than I actually need (hence more expensive board) trying to match the classic outline of full size/normal orientation Arduino shields.

  6. Pingback: Chipper – ATtiny Programming and Prototyping Shield | Free Plans Online

  7. Hi Ben,
    Received my assembled chipper this week. Vey cool. Congratulations on your success.
    I noticed on my pre-assembled board that 2 of the 3 sockets are installed backwards. Just a heads up, someone might get confused as to how to orient the processor they are trying to program.

    Thanks Again

  8. Ok I received mine the other day and have assembled it. started reading the doc you provided about flashing… Got the the part where you say it will only work on the UNO… WHAT? Why? So I see that the board has the two pins that are new to the UNO, IOREF and the other one, whatever it is. I looked at the gerber files you provided and those two pins are not connected to anything… SO I just removed them but still I’m not able to program the chips. The IDE just tells me it is the wrong device signature:

    avrdude: Device signature = 0x000000
    avrdude: Yikes! Invalid device signature.

    Now I know that this chip already has the right core on it. I swap it over to my other homemade programer/breakout board and it works. I can upload sketches to it no problem. Ok so now I have a chip with the blink sketch so I put it back in the chipper to light the LED just to test… No go.

    I verified;
    -the chip has power.
    – the pins directly on the chip all have continuity to both the ICSP port and the Shield pin ports. as well as the LED test pin at the high side of the resistor.
    – I verified I could light up the test LED if I pulled the chip and ran a blink signal directly into the chip header pin spot.
    – Tried multiple chips (all 84’s since that is all I have)

    What is next? any ideas?.

    • Also note that when I program the same chip on my homemade programmer it reports the device signature as:

      avrdude: Device signature = 0x1e930c

      I have also attempted both with the chipper being an arduino shield and the also via the ISCP port as I am with my board. The arduino in question and the PC are the same as are the hardware and board files. I have tried both 1k and 8k clocks.

      • SON OF A…. Well right after I wrote that last line it came to me… I burned all these chips ages ago with the bootloader for a 20MHz external clock since my board has that. SO I reburnt one to internal 1MHz clock, moved it over to the Chipper and on went the sketch! Blurg how simple and silly of me to have not gotten there before now. Sorry for anyone who reads this for you have wasted your time 😦 lol

        So a fresh chip or a proper bootloader and I would have been fine. blah! I guess the moral of this story is if someone buys chips with a bootloader already installed lets hope it doesn’t have the 20MHz clock flag set or they will have these same problems… and I don’t know of a way you could reburn off of the 20MHz bootloader with just the Chipper…

  9. Also while I’m here and typing away I have an idea for version V2 🙂 Making this a little wide and then adding a row of female headers along side each chip so that the chip could be left in the chipper while uploading programs and we would still have access to all the pins. It would save pulling the chips over and over and only add a tad bit of size and not much cost to the board. heck leave them unpopulated holes and we can get our own headers 🙂

  10. Just a small note. The link to the sponsors has some extra stuff on the end [%E2%80%8E] so it gives a page not found. I took that off and the page looks great otherwise.

  11. This might seem like a silly question, but I have an Arduino Uno to which I want to hookup my chipper. However, I’m unsure of which Arduino pins that go into which chipper pins.

    • For the pins labeled “SCK”,”GND” etc. if you connect “GND” to GND” next to D13, “SCK” to D13, “MISO” to D12 and so on it should work and the pins on the other side will fit into place.

  12. Hi Ben. Not sure if you’re still checking these comments, but I finally got around to assembling my Chipper. I have a problem with the connecting headers, though.
    If I line up the GND->GND, SCK->D13, etc., the other side’s pins would hang off my Uno’s power pins (too “low” by 2 pins); i.e. the two nearest the capacitor would not be connected. It’s the same on both my Unos. My Unos fit standard shields (e.g. from SparkFun), so what am I doing wrong?

    • Just figured it out: I was trying it on an Uno R2 board. I have an R3 as well but, will this work on the R2 at all (maybe with different pin assignments in the code)?

      • Looking at the pinouts it should work – everything is the same. The only difference is that the R2 will have 1 header pin floating on the Chipper above the RESET and IOREF header. That should not make a difference, though, and the software will be the same. Let me know what happens.

          • It would work. You just need to cut off those 2 header pins that are floating and touching the capacitor. They are not connected to anything. The board schematic and eagle files are available on my GitHub account or they come up if you just search Chipper Shield on GitHub.

  13. I had the same issue as C. Dodd. I plugged the Chipper with an ATTiny85 into an Arduino UNO R2. It works after clipping the two extra pins as you suggested. If you plug it in without clipping the two pins, and therefore plug it in wrong, the ATTiny85 gets very hot. It got hot enough to burn me, but not hot enough to ruin the ATTiny.

    It’s working great now.

  14. Hey Ben, got my board today and it went together pretty well. I’m curious about the correct ATTiny core files to load into the Arduino IDE – the link you provided goes to a deprecated file (ver. 015) and it recommends the current version 017. My problem is that the file structure is different than the installation guide you wrote. Which core files should I use?

  15. Got my chipper kit and cobbled it together… When I put it on the Arduino and plug in the arduino USB, should either of the lights on the chipper come on?

    The uploads run, but I have to hit the reset button on the chipper between uploading the attiny85 bootloader and uploading a sketch. Once the upload was complete, I tried the chip on a breadboard, but didn’t get any output (i.e. blinking light) so I’m not sure that it actually loaded anything onto the 85.

    The chip I tried was an ATTINY85V-10PU.

    • Lights should only come on in the Chipper when you program the ATtiny to light them up.

      Are you sure that you have the correct pin out for the ATtiny? Try connecting an LED to each pin one at a time.

      Also as you have mentioned try using Arduino 1.0.2. A lot changes in the 1.0.5 version.

  16. Almost forgot… The hardware directory with the ATTiny files do not work at all with the Arduino program version 1.5 beta. They don’t show up in the board menu. It does work on 1.0.

      • Hi, so it does work using 1.5.4? Where in that link you posted should I find the solution? Currently I have it working on 1.0.5

        cheers,
        Gus

        • The key difference is that the files now go in the package contents, not the sketch folder. here’s a summary of what you need to do:
          0. quit arduino – close the app.
          1. right/ctrl-click the arduino 1.5.x application
          2. click ‘show package contents’
          3. find the /resources/java/hardware/arduino/avr directory – in there you’ll see a hardware folder – this is where the tiny files go.
          4. double click on the boards.txt file in the /resources/java/hardware/arduino/avr directory – you are going to append the contents of the boards file with the attiny descriptions to this file.
          5. copy the contents of the boards.txt file from (cmd-a, cmd-c) the tiny folder you downloaded, and paste it at the end of the boards.txt file in the /resources/java/hardware/arduino/avr directory. Save this file and close the editor.
          6. finally, open the directory called variants. in there you’ll see some directories for leonardo, standard, etc.
          7. drag and drop the tiny folder that you downloaded (it has all of the core files – .h, .c, .cpp) and put it into the variants folder.
          8. start the arduino app. click on tools>boards, and you should see a really long list of boards, including the attiny boards.

          Note: watch for CAPS – these directories are all lower case, and it appears to matter…

          Let me know if you get stuck?

          • I have setup the folders as per your screenshot. And edited the boards.txt file. I can now see and select the attiny boards in the IDE menu.
            When trying to compile the blink example I get these messages:

            Blink.ino:10:21: error: Arduino.h: No such file or directory
            Blink.ino: In function ‘void setup()’:
            Blink:15: error: ‘OUTPUT’ was not declared in this scope
            Blink:15: error: ‘pinMode’ was not declared in this scope
            Blink.ino: In function ‘void loop()’:
            Blink:20: error: ‘HIGH’ was not declared in this scope
            Blink:20: error: ‘digitalWrite’ was not declared in this scope
            Blink:21: error: ‘delay’ was not declared in this scope

          • This series of errors has to do with a problem with an include in the Arduino.h file. WProgram.h is referred to in v15 of the Attiny set, but not in v17. I’ll troubleshoot this on the weekend when I have more time to figure it out.

            Unless Ben wants to take a shot? Seems he’s not paying attention to 1.5.x.

    • Hi Gus, not a noob question at all. What I mean by that is that the pin is broken out for easy access so you could attach a sensor (ex. pushbutton) and when the button was pressed the LEDs would light up. You could just as easily use the pin to output a signal.

      If you look on the Chipper you have, towards the top left side of the board (as a reference if you were to read builtbyben.net on the board) you should see 85,84 and 2313 next to a hole on the board that you could solder something onto. The hole closets to 85 will connect to an ATtiny85 when you have one plugged in and the same for the other 2 holes. Let me know if you have any more questions.

      • Hi Ben,
        Ah thanks, I understand now and tested it successfully. On the 85 PB3 is connected to the broken out port. And PB4 is connected to the onboard led in the top right corner.

        Gus

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s